PT-2018-15192

CVE-2018-1999007

·

Publicado

2018-07-23

·

Atualizado

2022-06-13

Descrição por

CVSS 3.1
5.4
Média
MétricasAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Jenkins versions 2.132 and earlier Jenkins versions 2.121.1 and earlier
Description A cross-site scripting issue exists in the Stapler web framework's org/kohsuke/stapler/Stapler.java, allowing attackers who can control certain URLs in Jenkins to define JavaScript that would be executed in another user's browser when that user views HTTP 404 error pages while Stapler debug mode is enabled.
Recommendations For Jenkins versions 2.132 and earlier, update to a version later than 2.132 to resolve the issue. For Jenkins versions 2.121.1 and earlier, update to a version later than 2.121.1 to resolve the issue. As a temporary workaround, consider disabling Stapler debug mode until a patch is available.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-6456-XJM5-G3PG
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾