PT-2018-16488
CVE-2018-4220
·
Publicado
2018-06-08
·
Atualizado
2019-10-03
Descrição por
CVSS 2.0
9.3
AltaMétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Swift versions prior to 4.1.1 Security Update 2018-001
Description
The issue involves the "Swift for Ubuntu" component and allows attackers to execute arbitrary code in a privileged context. This is possible because write and execute permissions are enabled during library loading.
Recommendations
For versions prior to 4.1.1 Security Update 2018-001, update to Swift 4.1.1 Security Update 2018-001 to resolve the issue. As a temporary workaround, consider restricting the use of the "Swift for Ubuntu" component until the update is applied.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾