PT-2018-17609
CVE-2018-6521
·
Publicado
2018-02-02
·
Atualizado
2022-05-13
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
SimpleSAMLphp versions prior to 1.15.2
Description
The issue is related to the sqlauth module in SimpleSAMLphp, which relies on the MySQL utf8 charset. This charset truncates queries when it encounters four-byte characters, potentially allowing remote attackers to bypass intended access restrictions.
Recommendations
For versions prior to 1.15.2, update to version 1.15.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the sqlauth module until a patch is applied.
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾