PT-2018-18227

CVE-2018-7711

·

Publicado

2018-03-05

·

Atualizado

2022-05-14

Descrição por

CVSS 3.1
8.1
Alta
MétricasAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: SimpleSAMLphp versions prior to 1.15.4
Description: The issue arises from an incorrect check of return values in the signature validation utilities within the saml2 library of SimpleSAMLphp. This allows an attacker to force an error during validation, resulting in invalid signatures being accepted as valid. The problem stems from a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Recommendations: For versions prior to 1.15.4, update to version 1.15.4 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-G888-G2PP-82HF
DLA-1314-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾