PT-2018-2216
CVE-2018-1126
·
Publicado
2018-05-17
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
procps-ng versions prior to 3.3.15
Description
The issue is related to an integer overflow in the file2strvec function of the procps-ng utility set, which can be exploited by a remote attacker to elevate privileges and execute arbitrary code. The problem arises from an incorrect integer size in proc/alloc, leading to truncation and integer overflow issues.
Recommendations
For versions prior to 3.3.15, update to version 3.3.15 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable function until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾