PT-2018-2295
CVE-2018-16509
·
Publicado
2018-08-21
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
9.3
AltaMétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions prior to 9.24
Description
An issue in Artifex Ghostscript allows attackers to execute code using the "pipe" instruction by supplying crafted PostScript, due to incorrect "restoration of privilege" checking during handling of /invalidaccess exceptions. This could enable a remote attacker to load specially crafted PostScript code and, as a result, execute arbitrary code.
Recommendations
For versions prior to 9.24, update to version 9.24 or later to resolve the issue. As a temporary workaround, consider restricting the use of the "pipe" instruction in crafted PostScript code until a patch is applied.
Explorabilidade
Exploit
Correção
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾