PT-2018-2699
CVE-2019-9924
·
Publicado
2018-11-14
·
Atualizado
2022-04-05
Descrição por
CVSS 3.1
7.8
AltaMétricasAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Bash versions prior to 4.4-beta2
Description
The issue is related to the restricted command interpreter rbash in Bash, which is associated with insufficient checking of the BASH CMDS array values. This could allow an attacker to execute arbitrary commands. The problem arises because rbash does not prevent the shell user from modifying BASH CMDS, thus enabling the user to execute any command with the permissions of the shell.
Recommendations
For versions prior to 4.4-beta2, update to version 4.4-beta2 or later to resolve the issue. As a temporary workaround, consider restricting access to the BASH CMDS array to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾