PT-2018-3005

CVE-2019-3855

·

Publicado

2018-12-03

·

Atualizado

2026-10-14

Descrição por

CVSS 2.0
9.3
Alta
MétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions libssh2 versions prior to 1.8.1
Description The issue is related to an integer overflow in the libssh2 library, which can be exploited by a remote attacker to execute arbitrary code on the client system when a user connects to a compromised SSH server. The vulnerability is associated with the libssh2 transport read function in the src/transport.c file and occurs when reading packets from the server.
Recommendations For libssh2 versions prior to 1.8.1, update to version 1.8.1 or later to resolve the issue. As a temporary workaround, consider restricting access to SSH servers until the update is applied. Avoid using the libssh2 transport read function until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2019-1501
CESA-2019_0679
CESA-2019_1175
CESA-2019_1652
DLA-1730-1
DLA-1730-3
DSA-4431-1
MGASA-2019-0139
OPENSUSE-SU-2019_1075-1
OPENSUSE-SU-2019:1109-1
OPENSUSE-SU-2019_1109-1
OPENSUSE-SU-2020:2126-1
OPENSUSE-SU-2020_2126-1
OPENSUSE-SU-2020:2129-1
OPENSUSE-SU-2020_2129-1
OPENSUSE-SU-2024:10999-1
RHSA-2019:0679
RHSA-2019_0679
RHSA-2019:1175
RHSA-2019_1175
RHSA-2019:1652
RHSA-2019_1652
RHSA-2019:1791
RHSA-2019:1943
RHSA-2019:2399
SUSE-SU-2019:0655-1
SUSE-SU-2019_0655-1
SUSE-SU-2019:13982-1
SUSE-SU-2019_13982-1
SUSE-SU-2019:13997-1
SUSE-SU-2020:3551-1
USN-5308-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾