PT-2018-3209
CVE-2018-16802
·
Publicado
2018-09-10
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
7.8
AltaMétricasAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions prior to 9.25
Description
The issue exists due to insufficient input validation in the Ghostscript software, which can allow an attacker to execute arbitrary code by supplying crafted PostScript. This is related to incorrect "restoration of privilege" checking when running out of stack during exception handling, specifically with the use of the "pipe" instruction.
Recommendations
For Artifex Ghostscript versions prior to 9.25, update to version 9.25 or later to resolve the issue. As a temporary workaround, consider restricting the use of crafted PostScript to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾