PT-2018-4551

CVE-2015-9238

·

Publicado

2018-05-31

·

Atualizado

2019-10-09

Descrição por

CVSS 2.0
5.0
Média
MétricasAV:N/AC:L/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions secure-compare versions prior to 3.0.1
Description The issue arises from the secure-compare function comparing the first argument with itself instead of comparing two different strings. This results in the function always returning true when comparing two strings of the same length, regardless of their actual contents.
Recommendations For versions prior to 3.0.1, upgrade to version 3.0.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-H9X2-5RM7-X4GM
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾