PT-2018-9239
CVE-2018-1000052
·
Publicado
2018-02-09
·
Atualizado
2020-08-24
Descrição por
CVSS 3.1
7.5
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions:
fmtlib versions prior to 4.1.0
Description:
The issue is related to a memory corruption problem that can cause a Denial of Service. It occurs when an invalid format specifier is used in the
fmt::print() function, resulting in a SIGSEGV due to memory corruption. This can be exploited by specifying an invalid format specifier in the fmt::print() function.Recommendations:
For versions prior to 4.1.0, update to version 4.1.0 or later to resolve the issue. As a temporary workaround, consider validating format specifiers before passing them to the
fmt::print() function to minimize the risk of exploitation.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾