PT-2019-12044
CVE-2019-10773
·
Publicado
2019-12-16
·
Atualizado
2026-10-07
Descrição por
CVSS 3.1
7.8
AltaMétricasAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Yarn versions prior to 1.21.1
Description
The package install functionality in Yarn can be exploited to create arbitrary symlinks on the host filesystem. This can be achieved by using specially crafted "bin" keys. Depending on the current user's permission set, existing files could be overwritten.
Recommendations
For versions prior to 1.21.1, update to version 1.21.1 or later to resolve the issue. As a temporary workaround, consider restricting the package install functionality until the update is applied.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾