PT-2019-12680

CVE-2019-12174

·

Publicado

2019-07-08

·

Atualizado

2020-08-24

Descrição por

CVSS 3.1
7.8
Alta
MétricasAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions hide.me version prior to 2.4.4
Description The issue arises from a privilege escalation vulnerability in the connectWithExecutablePath:configFilePath:configFileName method of the me hide vpnhelper.Helper class. This method is susceptible to user-supplied input, allowing for privilege escalation and the ability to run any application on the system in the root context.
Recommendations For versions prior to 2.4.4, update to version 2.4.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the connectWithExecutablePath:configFilePath:configFileName method of the me hide vpnhelper.Helper class until a patch is applied.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾