PT-2019-12971

CVE-2019-12829

·

Publicado

2019-06-15

·

Atualizado

2021-07-21

Descrição por

CVSS 3.1
7.5
Alta
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions radare2 versions prior to 3.5.1
Description The issue is related to the mishandling of the RParse API, which can be exploited by remote attackers to cause a denial of service, resulting in an application crash, or possibly have other unspecified impacts. This is demonstrated by newstr buffer overflows during replace operations, affecting specific files such as libr/asm/asm.c and libr/parse/parse.c.
Recommendations For versions prior to 3.5.1, update to version 3.5.1 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
ALT-PU-2019-2162
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾