PT-2019-13061

CVE-2019-12970

·

Publicado

2019-07-01

·

Atualizado

2021-01-08

Descrição por

CVSS 3.1
6.1
Média
MétricasAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions SquirrelMail versions 1.4.22 and earlier SquirrelMail versions 1.5.x through 1.5.2
Description A security issue was discovered due to improper handling of RCDATA and RAWTEXT type elements, allowing the built-in sanitization mechanism to be bypassed. This can lead to the execution of malicious script content from HTML e-mail within the application context via crafted use of elements such as NOEMBED, NOFRAMES, NOSCRIPT, or TEXTAREA.
Recommendations For SquirrelMail versions 1.4.22 and earlier, update to a version later than 1.4.22 to resolve the issue. For SquirrelMail versions 1.5.x through 1.5.2, update to a version later than 1.5.2 to resolve the issue. As a temporary workaround, consider restricting the use of potentially vulnerable elements such as NOEMBED, NOFRAMES, NOSCRIPT, or TEXTAREA until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
DLA-1868-1
MGASA-2021-0010
USN-4669-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾