PT-2019-13374
CVE-2019-13506
·
Publicado
2019-07-11
·
Atualizado
2019-07-18
Descrição por
CVSS 3.1
6.1
MédiaMétricasAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
@Nuxt/devalue versions prior to 1.2.3
Nuxt.js versions prior to 2.6.2
Description
The issue is related to the mishandling of object keys, leading to Cross-Site Scripting (XSS). Insufficient input sanitization allows an attacker to inject arbitrary JavaScript code through object keys.
Recommendations
For @Nuxt/devalue versions prior to 1.2.3, upgrade to version 1.2.3 or later.
For Nuxt.js versions prior to 2.6.2, upgrade to version 2.6.2 or later.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾