PT-2019-14540
CVE-2019-16144
·
Publicado
2019-09-06
·
Atualizado
2021-08-25
Descrição por
CVSS 2.0
7.8
AltaMétricasAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
generator crate versions prior to 0.6.18
Description
The issue arises from the use of uninitialized memory by Scope, done, and yield during API calls. This can lead to undefined behavior (UB) in certain cases, such as using the API in a non-generator context.
Recommendations
For versions prior to 0.6.18, update to version 0.6.18 or later to resolve the issue. As a temporary workaround, consider avoiding the use of affected APIs in non-generator contexts until the update is applied.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾