PT-2019-14844

CVE-2019-16885

·

Publicado

2019-12-03

·

Atualizado

2020-08-24

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions OkayCMS versions prior to 2.3.5
Description The issue allows an unauthenticated attacker to achieve remote code execution by injecting a malicious PHP object via a crafted cookie. This can occur in two places: first in view/ProductsView.php using the cookie price filter, and second in api/Comparison.php via the cookie comparison.
Recommendations For versions prior to 2.3.5, update to version 2.3.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the view/ProductsView.php and api/Comparison.php files until a patch is available. Avoid using the cookies price filter and comparison in the affected API endpoints until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾