PT-2019-15119
CVE-2019-17383
·
Publicado
2019-10-09
·
Atualizado
2022-07-19
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
netaddr gem versions prior to 2.0.4
netaddr gem versions prior to 1.5.3
Description
The issue is related to misconfigured file permissions in the netaddr gem for Ruby. When a gem is installed, it may result in 0777 permissions in the target filesystem.
Recommendations
For versions prior to 1.5.3, update to version 1.5.3 or later.
For versions prior to 2.0.4, update to version 2.0.4 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾