PT-2019-1695
CVE-2019-3835
·
Publicado
2019-02-14
·
Atualizado
2024-06-15
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Ghostscript versions prior to 9.27
Description
The issue is related to the superexec operator being available in the internal dictionary in Ghostscript, which could allow a specially crafted PostScript file to access the file system outside of the constraints imposed by -dSAFER. This flaw is associated with insecure privilege management, potentially enabling a remote attacker to elevate their privileges.
Recommendations
For Ghostscript versions prior to 9.27, update to version 9.27 or later to resolve the issue.
As a temporary workaround, consider restricting access to the superexec operator in the internal dictionary until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾