PT-2019-17516

CVE-2019-5226

·

Publicado

2019-11-29

·

Atualizado

2021-07-21

Descrição por

CVSS 3.1
5.5
Média
MétricasAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions Huawei P30 versions prior to ELLE-AL00B 9.1.0.193(C00E190R2P1) Huawei P30 Pro versions prior to VOGUE-AL00A 9.1.0.193(C00E190R2P1) Huawei Mate 20 versions prior to Hima-AL00B 9.1.0.135(C00E133R2P1) Huawei HiSuite versions prior to 9.1.0.305
Description The issue is related to a version downgrade vulnerability. It occurs because the device and HiSuite software do not validate the upgrade package sufficiently, allowing the system of the smartphone to be downgraded to an older version.
Recommendations For Huawei P30 versions prior to ELLE-AL00B 9.1.0.193(C00E190R2P1), update to ELLE-AL00B 9.1.0.193(C00E190R2P1) or later. For Huawei P30 Pro versions prior to VOGUE-AL00A 9.1.0.193(C00E190R2P1), update to VOGUE-AL00A 9.1.0.193(C00E190R2P1) or later. For Huawei Mate 20 versions prior to Hima-AL00B 9.1.0.135(C00E133R2P1), update to Hima-AL00B 9.1.0.135(C00E133R2P1) or later. For Huawei HiSuite versions prior to 9.1.0.305, update to HiSuite 9.1.0.305 or later.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾