PT-2019-1896

CVE-2019-9023

·

Publicado

2019-01-17

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.40 PHP versions 7.0.x through 7.1.25 PHP versions 7.2.x through 7.2.13 PHP versions 7.3.x through 7.3.0
Description The issue is related to heap-based buffer over-read instances in mbstring regular expression functions when supplied with invalid multibyte data. This can occur in various files, including regcomp.c, regexec.c, regparse.c, unicode.c, and utf32 be.c, when a multibyte regular expression pattern contains invalid multibyte sequences. Exploitation of this issue may allow a remote attacker to cause a denial of service, breach confidentiality, and integrity of protected data by sending specially crafted data.
Recommendations For PHP versions prior to 5.6.40, update to version 5.6.40 or later. For PHP versions 7.0.x through 7.1.25, update to version 7.1.26 or later. For PHP versions 7.2.x through 7.2.13, update to version 7.2.14 or later. For PHP versions 7.3.x through 7.3.0, update to version 7.3.1 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
ALSA-2020:1624
ALT-PU-2019-1060
CESA-2020_1624
DLA-1679-1
DSA-4398-1
OPENSUSE-SU-2019_1256-1
OPENSUSE-SU-2019_1293-1
OPENSUSE-SU-2019:1572-1
OPENSUSE-SU-2019_1572-1
OPENSUSE-SU-2019:1573-1
OPENSUSE-SU-2019_1573-1
OPENSUSE-SU-2022_4067-1
OPENSUSE-SU-2024:11167-1
OPENSUSE-SU-2024:11169-1
RHSA-2019:2519
RHSA-2019:3299
RHSA-2020:1624
RHSA-2020_1624
RLSA-2020:1624
SUSE-RU-2019:0823-1
SUSE-SU-2019:0985-1
SUSE-SU-2019:14013-1
SUSE-SU-2019_14013-1
SUSE-SU-2019:1461-1
SUSE-SU-2019_1461-1
SUSE-SU-2022:4067-1
USN-3902-1
USN-3902-2
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾