PT-2019-19422

CVE-2019-9185

·

Publicado

2019-03-07

·

Atualizado

2022-05-13

Descrição por

CVSS 3.1
8.8
Alta
MétricasAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Bolt versions prior to 3.6.5
Description The issue allows remote attackers to execute arbitrary PHP code by renaming a previously uploaded file to have a .php extension. This is possible due to a flaw in the Controller/Async/FilesystemManager.php file in the filemanager.
Recommendations For versions prior to 3.6.5, update to version 3.6.5 or later to resolve the issue. As a temporary workaround, consider restricting file upload and rename capabilities to minimize the risk of exploitation. Avoid allowing users to upload files with .php extensions until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-GMG5-F2GM-P3H7
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾