PT-2019-20019
Publicado
2019-06-13
·
Atualizado
2019-06-13
Descrição por
CVSS 3.1
7.3
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
@apollo/gateway versions prior to 0.6.2
Description
The issue allows attackers to alter the Object prototype through queries with GraphQL aliases, potentially leading to Denial of Service or Remote Code Execution when chained with other vulnerabilities. This is due to the use of deepMerge() to merge objects, which can be exploited with carefully constructed payloads to override properties of all objects in the application.
Recommendations
Upgrade to version 0.6.2 or later.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾