PT-2019-2883

CVE-2019-10161

·

Publicado

2019-06-20

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
8.8
Alta
MétricasAV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions libvirtd versions prior to 4.10.1 libvirtd versions prior to 5.4.1
Description The issue is related to the virDomainSaveImageGetXMLDesc() API, which has access control errors. This allows an attacker with access to the libvirtd socket to probe the existence of arbitrary files, cause denial of service, or execute arbitrary programs by specifying an arbitrary path that would be accessed with the permissions of the libvirtd process.
Recommendations For libvirtd versions prior to 4.10.1, update to version 4.10.1 or later. For libvirtd versions prior to 5.4.1, update to version 5.4.1 or later. As a temporary workaround, consider restricting access to the virDomainSaveImageGetXMLDesc() API until a patch is available.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2019-2222
ALT-PU-2019-2225
CESA-2019_1578
CESA-2019_1579
CESA-2019_1580
DLA-1832-1
DSA-4469-1
MGASA-2019-0390
OPENSUSE-SU-2019:1672-1
OPENSUSE-SU-2019_1672-1
OPENSUSE-SU-2019:1753-1
OPENSUSE-SU-2019_1753-1
OPENSUSE-SU-2024:11008-1
RHSA-2019:1578
RHSA-2019_1578
RHSA-2019:1579
RHSA-2019_1579
RHSA-2019:1580
RHSA-2019_1580
RHSA-2019:1699
RHSA-2019:1762
SUSE-SU-2019:14097-1
SUSE-SU-2019_14097-1
SUSE-SU-2019:14100-1
SUSE-SU-2019:1599-1
SUSE-SU-2019_1599-1
SUSE-SU-2019:1637-1
SUSE-SU-2019_1637-1
SUSE-SU-2019:1643-1
SUSE-SU-2019_1643-1
SUSE-SU-2019:1686-1
SUSE-SU-2019_1686-1
SUSE-SU-2019:1690-1
SUSE-SU-2019_1690-1
SUSE-SU-2019:2105-1
SUSE-SU-2019_2105-1
SUSE-SU-2019:2227-1
SUSE-SU-2019_2227-1
SUSE-SU-2019:2227-2
SUSE-SU-2019_2227-2
USN-4047-1
USN-4047-2
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾