PT-2019-2934
CVE-2019-9917
·
Publicado
2019-03-27
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
6.5
MédiaMétricasAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
ZNC versions prior to 1.7.3-rc1
Description
The issue allows an existing remote user to cause a Denial of Service (crash) via invalid encoding. It is due to insufficient input validation in the mechanism for disconnecting clients from the IRC server or a selected channel. This can be exploited by a remote attacker to cause a denial of service.
Recommendations
For versions prior to 1.7.3-rc1, update to version 1.7.3-rc1 or later to resolve the issue. As a temporary workaround, consider restricting access to the ZNC service to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾