PT-2019-3233

CVE-2019-10216

·

Publicado

2019-08-02

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
7.8
Alta
MétricasAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Ghostscript versions prior to 9.50
Description The issue is related to the .buildfont1 procedure in Ghostscript, which did not properly secure its privileged calls, allowing scripts to bypass -dSAFER restrictions. An attacker could exploit this flaw by creating a specially crafted PostScript file to escalate privileges and access files outside of restricted areas. This could potentially be used to execute arbitrary code in the system.
Recommendations For Ghostscript versions prior to 9.50, update to version 9.50 or later to resolve the issue. As a temporary workaround, consider restricting access to the .buildfont1 procedure until a patch is available. Avoid processing specially crafted PostScript files that could exploit this vulnerability.
Explorabilidade
Exploit
Correção
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2020-2917
ALT-PU-2020-2921
ALT-PU-2020-3124
CESA-2019_2465
DLA-1880-1
DSA-4499-1
MGASA-2019-0236
OPENSUSE-SU-2019:2139-1
OPENSUSE-SU-2019_2139-1
OPENSUSE-SU-2019:2160-1
OPENSUSE-SU-2019_2160-1
OPENSUSE-SU-2024:10783-1
RHSA-2019:2462
RHSA-2019_2462
RHSA-2019:2465
RHSA-2019_2465
SUSE-SU-2019:2347-1
SUSE-SU-2019_2347-1
SUSE-SU-2019:2348-1
SUSE-SU-2019_2348-1
USN-4092-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾