PT-2019-3586
CVE-2019-3863
·
Publicado
2019-03-18
·
Atualizado
2026-10-14
Descrição por
CVSS 3.1
8.8
AltaMétricasAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libssh2 versions prior to 1.8.1
Description
A flaw in libssh2 allows a server to send multiple keyboard interactive response messages with a total length greater than the maximum unsigned char characters. This can cause an out of bounds memory write error. The issue is related to a buffer overflow in memory, which can be exploited by a remote attacker to cause a denial of service, execute arbitrary code, or disclose sensitive information.
Recommendations
For versions prior to 1.8.1, update to version 1.8.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the libssh2 library until a patch is applied.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾