PT-2019-3933
CVE-2019-0188
·
Publicado
2019-05-28
·
Atualizado
2021-03-15
Descrição por
CVSS 2.0
7.8
AltaMétricasAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Apache Camel versions prior to 2.24.0
Description
The issue is related to an XML external entity injection (XXE) vulnerability due to the use of an outdated vulnerable JSON-lib library. This affects the camel-xmljson component. The vulnerability can be exploited by a remote attacker to perform an XXE attack.
Recommendations
For versions prior to 2.24.0, update to version 2.24.0 or later to resolve the issue. As a temporary workaround, consider disabling the camel-xmljson component until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾