PT-2019-4888
CVE-2019-12523
·
Publicado
2019-11-14
·
Atualizado
2026-10-21
Descrição por
CVSS 3.1
8.5
AltaMétricasAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Squid versions prior to 4.9
Description
The issue exists due to insufficient input validation in the Squid proxy server, allowing a remote attacker to access restricted HTTP servers using a specially crafted HTTP request. When handling a URN request, a corresponding HTTP request is made without going through the access checks that incoming HTTP requests go through, causing all access checks to be bypassed. This allows access to restricted HTTP servers, such as those that only listen on localhost.
Recommendations
For Squid versions prior to 4.9, update to version 4.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the URN request handling functionality until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾