PT-2019-5184
CVE-2019-18676
·
Publicado
2019-11-14
·
Atualizado
2026-10-21
Descrição por
CVSS 3.1
8.5
AltaMétricasAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Squid versions 3.x through 4.8
Description
An issue was discovered due to incorrect input validation, resulting in a heap-based buffer overflow that can cause Denial of Service to all clients using the proxy. The severity is high because this issue occurs before normal security checks, allowing any remote client that can reach the proxy port to perform the attack via a crafted URI scheme.
Recommendations
For Squid versions 3.x through 4.8, update to a version later than 4.8 to resolve the issue.
As a temporary workaround, consider restricting access to the proxy port to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾