PT-2019-5476

CVE-2019-9894

·

Publicado

2019-03-21

·

Atualizado

2019-05-07

Descrição por

CVSS 2.0
7.8
Alta
MétricasAV:N/AC:L/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions PuTTY versions prior to 0.71
Description A remotely triggerable memory overwrite issue exists in the RSA key exchange of PuTTY. This issue can be exploited before host key verification, potentially allowing a remote attacker to overwrite files in the system. The vulnerability is related to errors in key management.
Recommendations For versions prior to 0.71, update to version 0.71 or later to resolve the issue. As a temporary workaround, consider restricting access to the RSA key exchange functionality until a patch is applied. Avoid using the vulnerable RSA key exchange in PuTTY until the issue is resolved.
Explorabilidade
Correção
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
DLA-1763-1
DSA-4423-1
MGASA-2019-0153
OPENSUSE-SU-2019:1113-1
OPENSUSE-SU-2019_1113-1
OPENSUSE-SU-2019:1123-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾