PT-2019-5888
CVE-2019-19246
·
Publicado
2019-11-25
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
8.8
AltaMétricasAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Oniguruma versions prior to 6.9.4
Description
The issue is related to a heap-based buffer over-read in the
str lower case match function within the Oniguruma library, which is used for regular expression processing. This can potentially allow a remote attacker to cause a denial of service.Recommendations
For Oniguruma versions prior to 6.9.4, update to version 6.9.4 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
str lower case match function in the Oniguruma library until a patch is available.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾