PT-2019-6942
CVE-2013-4303
·
Publicado
2013-09-13
·
Atualizado
2019-12-19
Descrição por
CVSS 3.1
6.1
MédiaMétricasAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions 1.19.x through 1.19.7
MediaWiki versions 1.20.x through 1.20.6
MediaWiki versions 1.21.x through 1.21.1
Description
The issue allows remote attackers to conduct cross-site scripting (XSS) attacks. This is achieved via the
siprop parameter in a query action to "wiki/api.php". The problem arises when there is an even number of "." (period) characters in a string, which is not properly detected by the MediaWiki API.Recommendations
For MediaWiki versions 1.19.x through 1.19.7, update to version 1.19.8 or later.
For MediaWiki versions 1.20.x through 1.20.6, update to version 1.20.7 or later.
For MediaWiki versions 1.21.x through 1.21.1, update to version 1.21.2 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾