PT-2023-12595

CVE-2021-46872

·

Publicado

2023-01-13

·

Atualizado

2023-06-03

Descrição por

CVSS 3.1
6.1
Média
MétricasAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Nim versions prior to 1.6.2 NimForum versions prior to 2.2.0
Description An issue in the RST module of the Nim language stdlib allows the javascript: URI scheme, potentially leading to XSS in some applications.
Recommendations For Nim versions prior to 1.6.2, update to version 1.6.2 or later to resolve the issue. For NimForum versions prior to 2.2.0, update to version 2.2.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the RST module in the Nim language stdlib until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2023-1935
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾