PT-2023-12842
CVE-2022-25967
·
Publicado
2023-01-30
·
Atualizado
2025-03-27
Descrição por
CVSS 3.1
8.8
AltaMétricasAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
eta versions prior to 2.0.0
Description
The issue allows for Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API. This is exploitable only for users who are rendering templates with user-defined data.
Recommendations
For versions prior to 2.0.0, update to version 2.0.0 or later to resolve the issue. As a temporary workaround, consider restricting the rendering of templates with user-defined data until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾