PT-2023-14513

CVE-2022-4459

·

Publicado

2023-02-06

·

Atualizado

2025-03-26

Descrição por

CVSS 3.1
5.4
Média
MétricasAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WP Show Posts WordPress plugin versions prior to 1.1.4
Description The issue is related to the WP Show Posts WordPress plugin, which does not validate and escape some of its shortcode attributes before outputting them back in the page. This could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privilege users such as admins.
Recommendations For versions prior to 1.1.4, update to version 1.1.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vulnerable shortcode attributes to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾