PT-2023-17337
CVE-2023-1917
·
Publicado
2023-06-09
·
Atualizado
2023-06-16
Descrição por
CVSS 3.1
5.4
MédiaMétricasAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
PowerPress plugin for WordPress versions up to, and including, 10.0
Description
The issue is related to Stored Cross-Site Scripting via the plugin's shortcode(s) due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 10.0, update to version 10.0.2 to address the issue.
For versions prior to 10.0.1, update to version 10.0.1 as a partial fix, then further update to version 10.0.2 for complete resolution.
As a temporary workaround, consider restricting access to the plugin's shortcode(s) until a patch is applied.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾