PT-2023-27058

CVE-2023-39659

·

Publicado

2023-08-15

·

Atualizado

2023-08-22

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions langchain langchain-ai versions 0.0.232 and earlier langchain langchain-ai versions prior to 0.0.325
Description An issue in langchain langchain-ai allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool. run component.
Recommendations For versions 0.0.232 and earlier, update to version 0.0.325 or later. For versions prior to 0.0.325, update to version 0.0.325 or later. As a temporary workaround, consider disabling the PythonAstREPLTool. run component until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-PRGP-W7VF-CH62
PYSEC-2023-147
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾