PT-2023-32244
CVE-2023-5659
·
Publicado
2023-11-07
·
Atualizado
2023-11-14
Descrição por
CVSS 3.1
6.4
MédiaMétricasAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Interact: Embed A Quiz On Your Site plugin for WordPress versions up to, and including, 3.0.7
Description
The issue arises from insufficient input sanitization and output escaping on user-supplied attributes in the 'interact-quiz' shortcode. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages. The injected scripts will execute whenever a user accesses the injected page.
Recommendations
For versions up to, and including, 3.0.7, update to a version later than 3.0.7 to resolve the issue.
As a temporary workaround, consider restricting access to the 'interact-quiz' shortcode for users with contributor-level and above permissions until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾