PT-2023-4093

CVE-2023-37582

·

Publicado

2023-07-12

·

Atualizado

2025-10-16

Descrição por

CVSS 2.0
10
Crítica
MétricasAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions RocketMQ versions prior to 4.9.7 RocketMQ versions prior to 5.1.2
Description The vulnerability in the RocketMQ NameServer component allows for remote command execution. This issue arises when NameServer addresses are exposed on the extranet without proper permission verification, enabling an attacker to exploit the vulnerability by using the update configuration function to execute commands as the system user that RocketMQ is running as.
Recommendations For RocketMQ 4.x, upgrade to version 4.9.7 or above. For RocketMQ 5.x, upgrade to version 5.1.2 or above.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-GPQ8-963W-8QC9
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾