PT-2023-4934

CVE-2023-39512

·

Publicado

2023-09-05

·

Atualizado

2026-09-30

Descrição por

CVSS 2.0
8.5
Alta
MétricasAV:N/AC:L/Au:S/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions Cacti versions prior to 1.2.25
Description The issue exists due to inadequate protection of the web page structure in the Cacti network monitoring tool. This allows a remote attacker to conduct cross-site scripting attacks. An authenticated user can poison data stored in the Cacti database, which will be viewed by administrative accounts and execute JavaScript code in the victim's browser. The vulnerability can be exploited by configuring a malicious device name, which can be done by a user with General Administration>Sites/Devices/Data permissions through the http://<HOST>/cacti/host.php endpoint. The malicious payload is rendered at the http://<HOST>/cacti/data sources.php endpoint.
Recommendations For versions prior to 1.2.25, upgrade to version 1.2.25 or later to resolve the issue. As a temporary workaround for users unable to update, manually filter HTML output to minimize the risk of exploitation. Restrict access to the data sources.php script and the host.php endpoint to minimize the risk of exploitation. Avoid using the device name configuration feature in Cacti until the issue is resolved.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-VQCC-5V63-G9Q7
ALT-PU-2023-7619
ALT-PU-2023-7621
ALT-PU-2024-7120
ALT-PU-2025-1813
CLEANSTART-2024-VT73052
DSA-5550-1
OPENSUSE-SU-2023:0275-1
OPENSUSE-SU-2024:13203-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾