PT-2023-7527
CVE-2023-49285
·
Publicado
2023-11-24
·
Atualizado
2026-09-29
Descrição por
CVSS 3.1
8.6
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Squid versions prior to 6.5
Description
The issue is related to a Buffer Overread bug in Squid, which can be exploited by a remote attacker to cause a Denial of Service (DoS) attack against Squid HTTP Message processing. This can be achieved by sending a specially crafted HTTP request. Squid is a caching proxy for the Web that supports HTTP, HTTPS, FTP, and more.
Recommendations
For Squid versions prior to 6.5, users are advised to upgrade to version 6.5 or later to fix the bug. There are no known workarounds for this issue. As a temporary workaround, consider restricting access to the Squid HTTP Message processing to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾