PT-2023-8905
CVE-2023-46118
·
Publicado
2023-10-23
·
Atualizado
2026-09-25
Descrição por
CVSS 2.0
6.1
MédiaMétricasAV:N/AC:L/Au:M/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
RabbitMQ versions prior to 3.11.24
RabbitMQ versions prior to 3.12.7
Description
The issue is related to the HTTP API of RabbitMQ, a multi-protocol messaging and streaming broker, which did not enforce an HTTP request body limit. This made it vulnerable to denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish very large messages over the HTTP API, causing the target node to be terminated by an "out-of-memory killer"-like mechanism.
Recommendations
For RabbitMQ versions prior to 3.11.24, update to version 3.11.24 or later to resolve the issue.
For RabbitMQ versions prior to 3.12.7, update to version 3.12.7 or later to resolve the issue.
As a temporary workaround, consider restricting access to the HTTP API to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾