PT-2025-15294
CVE-2025-32030
·
Publicado
2025-04-07
·
Atualizado
2026-09-01
Descrição por
CVSS 3.1
7.5
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Apollo Gateway versions prior to 2.10.1
Description
The issue concerns a vulnerability that allows queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. This leads to exponential resource usage when deeply nested and reused fragments are involved, resulting in excessive resource consumption and denial of service.
Recommendations
For versions prior to 2.10.1, update to version 2.10.1 to resolve the issue. As a temporary workaround, consider restricting the use of deeply nested and reused named fragments in queries to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾