PT-2025-32390
CVE-2025-4796
·
Publicado
2025-08-08
·
Atualizado
2025-10-25
Descrição por
CVSS 3.1
8.8
AltaMétricasAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Eventin versions through 4.0.34
Description
The Eventin plugin for WordPress is susceptible to privilege escalation, potentially leading to account takeover. This occurs because the plugin does not adequately validate a user’s identity or capabilities before allowing updates to user details, such as email addresses. Specifically, the
update item function within the EventinSpeakerApiSpeakerController class is affected. Unauthenticated attackers with contributor-level permissions or higher can exploit this flaw to modify the email addresses of any user, including administrators, and subsequently reset passwords to gain unauthorized access.Recommendations
Eventin versions prior to 4.0.34 are affected.
Update to a version later than 4.0.34.
As a temporary workaround, restrict access to the
update item function within the EventinSpeakerApiSpeakerController class.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾