PT-2026-26509
CVE-2026-33412
·
Publicado
2026-01-01
·
Atualizado
2026-10-16
Descrição por
CVSS 3.1
7.3
AltaMétricasAV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.2.0202
Description
Vim, a command line text editor, contains a flaw in its
glob() function on Unix-like systems. Including a newline character (
) within a pattern provided to glob() could allow an attacker to execute arbitrary shell commands. The vulnerability's impact is dependent on the user's 'shell' setting. This occurs when a Vimscript plugin passes untrusted user input into the glob() function.Recommendations
Update to version 9.2.0202 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾