PT-2010-1008
CVE-2011-0216
·
Published
2010-12-07
·
Updated
2013-02-07
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apple Safari version 5.0.6 and earlier
libxml2 versions 2.7.6 and earlier
Description
The issue is related to an off-by-one error in libxml, which can lead to a heap-based buffer overflow and application crash, allowing remote attackers to execute arbitrary code or cause a denial of service. Multiple vulnerabilities in the libxml2 package can also lead to disruption of confidentiality, integrity, and availability of protected information. These vulnerabilities can be exploited remotely.
Recommendations
For Apple Safari version 5.0.6 and earlier, update to version 5.0.6 or later to resolve the issue.
For libxml2 versions 2.7.6 and earlier, update to a version later than 2.7.6 to resolve the issue.
As a temporary workaround, consider restricting access to the libxml2 package to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾