PT-2010-1033
CVE-2010-2891
·
Published
2010-10-27
·
Updated
2024-06-15
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
libsmi versions prior to 0.4.8
Description
The issue affects the libsmi package, potentially leading to breaches of confidentiality, integrity, and availability of protected information. It can be exploited remotely. The problem is caused by a buffer overflow in the smiGetNode function, allowing attackers to execute arbitrary code via a specially crafted Object Identifier.
Recommendations
For versions prior to 0.4.8, update to version 0.4.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the smiGetNode function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾