PT-2010-1814

CVE-2009-5012

·

Published

2010-10-19

·

Updated

2022-05-02

Description by

CVSS 4.0
7.1
High
MetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions pyftpdlib versions prior to 0.5.2
Description The issue allows remote authenticated users to bypass intended access restrictions and list the root directory via an FTP session, due to the lack of required permissions for the MLST command in ftpserver.py.
Recommendations For versions prior to 0.5.2, update to version 0.5.2 or later to resolve the issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-H4G7-8M7R-87R9
PYSEC-2010-9
Found an issue in the description? Have something to add? Feel free to write us 👾